Service Degradation
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 08:17 EDT
Monitoring
Current status per Microsoft
Oct 10, 2024, 2:23 PM EDT

We’ve applied a configuration update and our testing indicates that this action has successfully mitigated impact. However, affected users will need to take action to apply the changes we’ve made and remediate the problem:

- Outlook client and app users should restart their client or app to apply our changes. Outlook desktop client users may need to perform this action twice due to caching issues.

- Outlook on the web users should refresh their sessions. If that does not mitigate the issue, users are encouraged to clear their browser cache and refresh their Outlook on the web session.

We’re working with impacted customers and are continuing to perform tests across the affected infrastructure to confirm that impact has been successfully addressed.

Next update by:
Thursday, October 10, 2024 at 3:30 PM EDT
Posted Oct 10, 2024 - 15:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 10, 2024 - 13:41 EDT
Identified
The following service alert has been issued by Microsoft.

Issue ID: MO907654
Affected services: Exchange Online, Microsoft 365 suite
Status: Service degradation
Issue type: Incident

User impact
Users may encounter performance issues with Outlook
More info
Users may notice Outlook using an increased amount of system resources, causing the client to freeze or crash.
Scope of impact
Impact is predominately to the Outlook client, though users of any connection method including Outlook on the web and Outlook mobile apps may be affected
Posted Oct 10, 2024 - 13:33 EDT
This incident affected: MS Outlook.